Knowledgebase: Email
The other party tells us they're getting 554 Security Error when trying to send us mails
Posted by , Last modified by Ashley L on 19 November 2019 02:08 PM

In light of POODLE attack being effectively possible, we have disabled SSLv3 on our servers.

When connecting via web-browser that doesn't support TLS, you would usually see human readable error specifying inability to establish SSLv3 connection.

When external mail client / MTA is trying to connect to our mail servers, it would error out with different messages. Most common of them is "554 Security Error." In case the party that's trying to send mail to your mailbox gets this message, you will need to get ahold of party's technical person and tell them about POODLE attack and necessity of upgrading their mailing software to support TLS.

 

(0 vote(s))
Helpful
Not helpful

Comments (0)